CERN Accelerating science

Issue running the TestHost.sh script in UBoxed

Hello,

I have tried to install and test an instance of “UBoxed” on a CentOS7 VM at my institute, following the instructions here:

The steps went smoothly until I tried to run the TestHost.sh script. This crashed with the following message:

[centos@science-box uboxed]$ sudo ./TestHost.sh

Setting up the tests...

Pulling Docker image...
Using default tag: latest
latest: Pulling from sciencebox/docker-images/selftest
Digest: sha256:fd295224f98ae105629d8a1094c81de5dca78a2080f31aab9fec11ea1e08df81
Status: Image is up to date for gitlab-registry.cern.ch/sciencebox/docker-images/selftest:latest

Starting the container...
d16dacf586fd39064d1a64597ffff5f70b8af7546054c713247b1458cfb3b56f

Running all tests...
  Logfile: # docker exec -it selftest less /root/selftest.d/test.log
running test_cernboxeosaccess.sh (container:cernbox)
ERROR running test docker (exit code 255)

Do you have any suggestions as to how I might be able to fix this?

Thanks and best wishes,

James Catmore (ATLAS, University of Oslo)

Some more info, running the first test manually I see:

    [root@f0e05ab7391a selftest.d]# docker exec -t $RUN_CONTAINER /$test
+ export EOS_MGM_URL=root://eos-mgm.demonet
+ EOS_MGM_URL=root://eos-mgm.demonet
+ echo 1
1
+ dd if=/dev/zero of=/tmp/largefile256.dat bs=1024 count=250
250+0 records in
250+0 records out
256000 bytes (256 kB) copied, 0.00134727 s, 190 MB/s
+ dd if=/dev/zero of=/tmp/largefile512.dat bs=1024 count=500
500+0 records in
500+0 records out
512000 bytes (512 kB) copied, 0.00431443 s, 119 MB/s
+ dd if=/dev/zero of=/tmp/largefile1024.dat bs=1024 count=1000
1000+0 records in
1000+0 records out
1024000 bytes (1.0 MB) copied, 0.00427166 s, 240 MB/s
+ dd if=/dev/zero of=/tmp/largefile10240.dat bs=1024 count=10000
10000+0 records in
10000+0 records out
10240000 bytes (10 MB) copied, 0.0397042 s, 258 MB/s
+ echo 2
2
+ FILES='/etc/passwd /tmp/largefile256.dat /tmp/largefile512.dat /tmp/largefile1024.dat /tmp/largefile10240.dat'
+ eos ls -ld /eos/docker/user/u/user0/
Unable to stat /eos/docker/user/u/user0; No such file or directory (errc=2) (No such file or directory)
+ sh /var/www/html/cernbox/cernbox_scripts/homedirscript.sh root://eos-mgm.demonet /eos/docker/user/ /eos/docker/proc/recycle/ user0
uid=1000(user0) gid=1000 groups=1000
id: cannot find name for group ID 1000
ERROR: cannot retrieve group name for the user user0

Hello @jcatmore and @maikenp
TestHost.sh is failing because it requires some updates, but the server should be working.
let’s try to use the service at http://your-ip:80 and let me know if it is working.

Cheers
Omar.

Hi @ozapatam,

it works! Amazing :slight_smile:

I’ll have a play with it now, and ask some of the Oslo people to do the same.

James.

@jcatmore
if you need any help, please let us know,
At this moment We are working in the GPU support for Kubernetes and for Single Host is ready
but it is in a testing phase.
Do you need GPU for your deployment?

Do you want to install it in kubernetes for production?
Cheers
Omar.

Hi,
Kubernetes could be interesting. Is that what is recommended for production?

Hi @maikenp ,

Yes, the Kubernetes flavor of ScienceBox is what we recommend if you want to have a production deployment.

Still, the single-node flavor is useful because it is easier to deploy and allows you to play with the platform and perhaps expose it to a small number of users to get feedback.

If as a second step you want to go for the Kubernetes deployment, we can of course assist you as well.

Cheers,

Enric