Install new h5py release

I need to upgrade h5py in SWAN but I’m not succeeding to to conflicts with dependencies.
bash-4.2$ pip install --upgrade --user h5py
Requirement already satisfied: h5py in /cvmfs/ (2.10.0)
Collecting h5py
Downloading h5py-3.6.0-cp37-cp37m-manylinux_2_12_x86_64.manylinux2010_x86_64.whl (4.1 MB)
|████████████████████████████████| 4.1 MB 4.3 MB/s
Requirement already satisfied: numpy>=1.14.5 in /cvmfs/ (from h5py) (1.18.2)
Requirement already satisfied: cached-property in /eos/home-i02/s/shelena/.local/lib/python3.7/site-packages (from h5py) (1.5.2)
Installing collected packages: h5py
ERROR: pip’s dependency resolver does not currently take into account all the packages that are installed. This behaviour is the source of the following dependency conflicts.
tensorflow-gpu 2.3.0 requires h5py<2.11.0,>=2.10.0, but you have h5py 3.6.0 which is incompatible.
tensorflow-gpu 2.3.0 requires scipy==1.4.1, but you have scipy 1.5.1 which is incompatible.
tensorflow 2.7.0 requires keras<2.8,>=2.7.0rc0, but you have keras 2.2.4 which is incompatible.
tensorflow 2.7.0 requires tensorboard~=2.6, but you have tensorboard 2.3.0 which is incompatible.
tensorflow 2.7.0 requires tensorflow-estimator<2.8,~=2.7.0rc0, but you have tensorflow-estimator 2.3.0 which is incompatible.
Successfully installed h5py-3.6.0

This last message is weird because it was not successful indeed:
bash-4.2$ pip list | grep h5py
h5py 2.10.0

What can be done?

Thanks a lot!
Best wishes,

Hi Helena,

Could you please open a ticket for the LCG librarians with a request to update the h5py package?

They are responsible for installing or upgrading packages in the LCG releases.