CERN Accelerating science

Installing Bokeh - Package Suggestion

Dear SWAN team,

Thanks a lot for putting in place such a great tool.

I tried to install bokeh and got the following:

bash-4.2$ pip install bokeh
Collecting bokeh
Requirement already satisfied: PyYAML>=3.10 in /cvmfs/sft.cern.ch/lcg/views/LCG_95apython3/x86_64-centos7-gcc7-opt/lib/python3.6/site-packages (from bokeh) (3.13)
Requirement already satisfied: six>=1.5.2 in /cvmfs/sft.cern.ch/lcg/views/LCG_95apython3/x86_64-centos7-gcc7-opt/lib/python3.6/site-packages (from bokeh) (1.11.0)
Requirement already satisfied: Jinja2>=2.7 in /cvmfs/sft.cern.ch/lcg/views/LCG_95apython3/x86_64-centos7-gcc7-opt/lib/python3.6/site-packages (from bokeh) (2.10)
Requirement already satisfied: tornado>=4.3 in /cvmfs/sft.cern.ch/lcg/views/LCG_95apython3/x86_64-centos7-gcc7-opt/lib/python3.6/site-packages (from bokeh) (5.1)
Requirement already satisfied: numpy>=1.7.1 in /cvmfs/sft.cern.ch/lcg/views/LCG_95apython3/x86_64-centos7-gcc7-opt/lib/python3.6/site-packages (from bokeh) (1.14.2)
Collecting packaging>=16.8 (from bokeh)
Using cached https://files.pythonhosted.org/packages/91/32/58bc30e646e55eab8b21abf89e353f59c0cc02c417e42929f4a9546e1b1d/packaging-19.0-py2.py3-none-any.whl
Requirement already satisfied: python-dateutil>=2.1 in /cvmfs/sft.cern.ch/lcg/views/LCG_95apython3/x86_64-centos7-gcc7-opt/lib/python3.6/site-packages (from bokeh) (2.7.3)
Collecting pillow>=4.0 (from bokeh)
Using cached https://files.pythonhosted.org/packages/d2/c2/f84b1e57416755e967236468dcfb0fad7fd911f707185efc4ba8834a1a94/Pillow-6.0.0-cp36-cp36m-manylinux1_x86_64.whl
Requirement already satisfied: MarkupSafe>=0.23 in /cvmfs/sft.cern.ch/lcg/views/LCG_95apython3/x86_64-centos7-gcc7-opt/lib/python3.6/site-packages (from Jinja2>=2.7->bokeh) (1.0)
Requirement already satisfied: pyparsing>=2.0.2 in /cvmfs/sft.cern.ch/lcg/views/LCG_95apython3/x86_64-centos7-gcc7-opt/lib/python3.6/site-packages (from packaging>=16.8->bokeh) (2.2.0)
py2neo 4.0.0 requires colorama, which is not installed.
py2neo 4.0.0 requires neo4j-driver>=1.6.0, which is not installed.
paramiko 2.4.0 requires bcrypt>=3.1.3, which is not installed.
paramiko 2.4.0 requires cryptography>=1.5, which is not installed.
paramiko 2.4.0 requires pyasn1>=0.1.7, which is not installed.
paramiko 2.4.0 requires pynacl>=1.0.1, which is not installed.
keras 2.2.0 has requirement keras_applications==1.0.2, but you’ll have keras-applications 1.0.6 which is incompatible.
keras 2.2.0 has requirement keras_preprocessing==1.0.1, but you’ll have keras-preprocessing 1.0.5 which is incompatible.
Installing collected packages: packaging, pillow, bokeh
Could not install packages due to an EnvironmentError: [Errno 30] Read-only file system: ‘/cvmfs/sft.cern.ch/lcg/releases/Python/3.6.5-54b64/x86_64-centos7-gcc7-opt/lib/python3.6/site-packages/packaging’

You are using pip version 10.0.1, however version 19.1.1 is available.
You should consider upgrading via the ‘pip install --upgrade pip’ command.

I wonder if you could please lend me a hand to correctly install the package.

Moreover, I think this can be a handy package for visualization and it could be included in LCG.

Again thank you very much.

Cheers!

Oscar

Dear Oscar,

Please follow the instructions here:

You can also find them in the help panel, in SWAN. Note the required --user flag.

1 Like

Thanks a lot! It worked perfectly.