CERN Accelerating science

Swan slides

Hello,

I started to use the swan to prepare slides using RISE/reveal (I plan to use this for the swan workshop).

I have the some issues and I wonder if there is some other users in the community to share best practices.

The first issue is that the slides have different sizes. Is there an autoscale setting?

When de-activating the slides, the notebook layout is broken (maybe CSS). Is it a known bug, do other people experience this?

What is the best way to upload the slides on indico?

I used the notebook metadata editor to customize reveals. Is this the most convenient way?

Cheers,
Riccardo

Hi Riccardo,

You had a very good idea :slight_smile:
As far as I saw in the documentation, yes, there is scaling. You can set these extra configs by editing the notebook metadata (EDIT > Edit Notebook Metadata), and add something like:

  "rise": {
    "width": "100%",
    "height": "100%",
    "margin": 0,
    "minScale": 1,
    "maxScale": 1
  }

You need to save and refresh the page to see the changes.
But since you say you already customized the notebook metadata, you probably already did this. And it’s the right (and I think the only) way of setting these options.

About the layout being broken, can you take a screenshot? I’m not seeing anything wrong on my side.

To add this to indico is another challenge. We could do a “open with SWAN” and run it from there. But I think it would be quicker just to export the slides (FILE > Download as > Reveal.js slides (.html)) and then add the file to indico.

Hope it helps,
Diogo

I tried, it works from Swan, but not when saving to html…

Probably those options are not added automatically and you have to edit the generated html to add them again.

Looks more like an issue with the latex installation on the box – I just tried on lxplus755 and got:

nbconvert.exporters.pdf.LatexFailed: PDF creating failed, captured latex output:
This is XeTeX, Version 3.1415926-2.5-0.9999.3 (TeX Live 2013)
 restricted \write18 enabled.
entering extended mode
(./notebook.tex
LaTeX2e <2011/06/27>
Babel <v3.8m> and hyphenation patterns for english, dumylang, nohyphenation, lo
aded.
(/usr/share/texlive/texmf-dist/tex/latex/base/article.cls
Document Class: article 2007/10/19 v1.4h Standard LaTeX document class
(/usr/share/texlive/texmf-dist/tex/latex/base/size11.clo))
(/usr/share/texlive/texmf-dist/tex/latex/base/fontenc.sty
(/usr/share/texlive/texmf-dist/tex/latex/base/t1enc.def))
(/usr/share/texlive/texmf-dist/tex/latex/psnfss/mathpazo.sty)
(/usr/share/texlive/texmf-dist/tex/latex/graphics/graphicx.sty
(/usr/share/texlive/texmf-dist/tex/latex/graphics/keyval.sty)
(/usr/share/texlive/texmf-dist/tex/latex/graphics/graphics.sty
(/usr/share/texlive/texmf-dist/tex/latex/graphics/trig.sty)
(/usr/share/texlive/texmf-dist/tex/latex/latexconfig/graphics.cfg)
(/usr/share/texlive/texmf-dist/tex/xelatex/xetex-def/xetex.def)))
(/usr/share/texlive/texmf-dist/tex/latex/caption/caption.sty
(/usr/share/texlive/texmf-dist/tex/latex/caption/caption3.sty))

! LaTeX Error: File `adjustbox.sty' not found.

Type X to quit or <RETURN> to proceed,
or enter new name. (Default extension: sty)

Enter file name:
! Emergency stop.
<read *>

l.42     \usepackage
                    {xcolor} % Allow colors to be defined^^M
No pages of output.
Transcript written on notebook.log.

Not sure how to fix that (or who can), though … :frowning:

HTH,
cheers, andreas