Tensorboard access

Tensorflow offers a nice visualisation tool for the model parameters: TensorBoard  |  TensorFlow
It can be launched directly from a notebook (or from the CLI), but then one needs to access it on another port. Is there any way to make this work with SWAN?

Of course, the current alternative is just to launch the tensorboard locally using the synce’d cernbox folder.

Hello Artur,

Thank you for the suggestion. This would be very nice to have indeed, even more now that we are starting to offer GPUs and GPU-enabled tensorflow in SWAN.

Is it absolutely necessary that there is a port open to the outside? Ideally, the notebook frontend should proxy the tensorboard, which would be opened as a local process listening on a local port. But to the outside everything should flow via the Jupyter websockets connection.

I wonder if that’s the case for e.g. :

Since we are moving soon(ish) to JupyterLab, it would be better to go for a JLab extension.

Hi Enric, indeed!

I have just found jupyter-tensorboard · PyPI
But somehow I cannot manage to get it running here over the extensions interface…


Yes actually the JLab extension I shared is based on that jupyter-tensorboard.

Did you try to install the extension on SWAN?

We’ll have a look with @ozapatam

Yes exactly, I tried installing on SWAN and the above screenshot is a result from that. I can’t see the jupyter-tensorflow in the notebook though…
Thanks a lot for checking!

Hello @alobanov
I went through https://pypi.org/project/jupyter-tensorboard
I am following the steps but it doesn’t work in SWAN,
I’m having the same issue.
I did the troubleshooting jupyter-tensorboard · PyPI
but it doesn’t work anyway.

Taking a look in the javascript console I am getting this

and checking the server extension jupyter tell me that it is ok

I think this is something we want in the future, may we can integrate this in our future Jupyterlab interface.


1 Like

Thanks for debugging Omar!
Yes I wonder how such extensions can be integrated in SWAN’s custom interface? Do you think it needs some further custom rework from your side then?
And: when is the JLab expected to go to production? :slight_smile:

Hello @alobanov

I can see it in our customized interface

the thing is that it is not working
I am getting this

I did not manage to put it to work.

The JupyterLab extension they have is even not working, hopefully, they can put it to work in the next months.

And for our JupyterLab interface, we are still in intensive development, we don’t have a date for the release.


Thanks @ozapatam for trying this out.

@alobanov if we go for one, we’ll go for the JLab one. But before, the extension needs to be migrated to JLab 3 (and fix the problems pointed out by Omar).

Anyway, we keep this on our list.

1 Like

Hi, so there seems to be an open issue about that and a proposed solution which is not on pip yet:

I still get the Error 500 as some others, but maybe you have more luck?

Thanks, it’s probably better to wait for that issue to be resolved, we’ll give it a try!